Outils pour utilisateurs

Outils du site


nucleo2020

Installation de STM32CubeIDE

stm32cubeide (v1.0.2 à l'iut) : https://www.st.com/en/development-tools/stm32cubeide.html#overview

https://www.st.com/content/st_com/en/products/development-tools/software-development-tools/stm32-software-development-tools/stm32-ides/stm32cubeide.html?dl=FwWyI0yHFn526f7IyVX%2FsQ%3D%3D%2Ck15pvqcUXJ2RLcDoY4Dxcxky4jBNeCSPumk3WMvhjbSMxlpw0plEBMvhL5kh3uvPZmXd%2BJ5OV5I7rt%2Bj5awD03DZONzMzagoIxuhBE7NAB6umFkmVKrqu1XHFtFJATbDrSlaTel1m39YgHkkB13AYXZKZSXwhsb3gUwBFL2ma%2Fn8gpWZ5RewBDW8Vz259J4tUh99amfa9SRGJzqYetML4UPBIlqueW%2FER2Wv4Qbj424TIQ2z7POebPyO7OdvtG2QD87e%2BIejlMozoiau7rUHS8bTcV7tnNpkEws7kKQgY9SRuy8lSY0l71lpckuVgRN4cTD1rK%2BmpTW1nFRpwGxMaiLyZRI9ZA02nozzegpqBetEDiOxmOOIxw8nttuORGHj4nYIoM56EeYPy%2BtgvHur4ism0Oe8A%2BHv3IUnGaipCdE%3D

récupérer version 1.0.2 en DEB et l'installer:

wget http://homepages.laas.fr/bvandepo/files/iut/nucleo_stm32_2020/st-stm32cubeide_1.0.2_3566_20190716_0927_amd64.deb_bundle.sh
unzip st-stm32cubeide_1.0.2_3566_20190716_0927_amd64.deb_bundle.sh.zip
sudo sh ./st-stm32cubeide_1.0.2_3566_20190716_0927_amd64.deb_bundle.sh

ca installe dans /etc/udev/rules.d

  1. rw-rw-r– 1 root root 627 juil. 16 2019 49-stlinkv2-1.rules
  2. rw-rw-r– 1 root root 503 juil. 16 2019 49-stlinkv2.rules
  3. rw-rw-r– 1 root root 885 juil. 16 2019 49-stlinkv3.rules

lancement avec:

/opt/st/stm32cubeide_1.0.2/stm32cubeide

pour que le debugguer qui utilise libusb fonctionne sur pc Bertrand, avant de lancer l'ide:

export LIBRARY_PATH=/lib/x86_64-linux-gnu/
export LD_LIBRARY_PATH=/lib/x86_64-linux-gnu/
/opt/st/stm32cubeide_1.0.2/stm32cubeide

Installation Hal Arduino

idéalement il faudrait récupérerer la dernière version sur github: https://github.com/stm32duino/Arduino_Core_STM32

cd ~/
git clone https://github.com/stm32duino/Arduino_Core_STM32

mais problème: la version récente n'est plus compatible avec la version installée à l'iut, utiliser plutot: ~/Arduino_Core_STM32.zip

mkdir -p ~/STM32Cube
cd ~/STM32Cube
wget http://homepages.laas.fr/bvandepo/files/iut/nucleo_stm32_2020/Arduino_Core_STM32.zip
unzip Arduino_Core_STM32.zip
rm Arduino_Core_STM32.zip

Installation des paquets correspondants à la carte STM32F334

Il faut faire un projet vide de test pour pouvoir charger les paquets correspondants à la carte de développement File→New→STM32 Project

Onglet “Board selector”

dans le champ loupe, saisir: F334R8 sélectionner la carte NUCLEO-F334R8, puis Next project name: test

Targetted language C++ j'ai mis Location à : “/home/bvandepo/STM32CubeIDE/workspace_1.0.2” Next

Firmware package Repository: location: /home/bvandepo/STM32Cube/Repository Finish

Initialise peripherals with default mode: Yes associate perspective: Yes

Téléchargement des paquets nécessaires: stm32cube_fw_f3_v1100.zip dans ~/STM32Cube/Repository/stm32cube_fw_f3_v1100.zip

tester la compilation et le debug de l'application de test en cliquant sur icone Bug

j'obtiens:

error
Log output file:   /tmp/STM32CubeProgrammer_tTTHHQ.log
/opt/st/stm32cubeide_1.0.2/plugins/com.st.stm32cube.ide.mcu.externaltools.cubeprogrammer.linux64_1.0.0.201904021149/tools/bin/STM32_Programmer_CLI: symbol lookup error: /opt/st/stm32cubeide_1.0.2/plugins/com.st.stm32cube.ide.mcu.externaltools.cubeprogrammer.linux64_1.0.0.201904021149/tools/bin/STM32_Programmer_CLI: undefined symbol: libusb_get_port_numbers
Encountered Error when opening /opt/st/stm32cubeide_1.0.2/plugins/com.st.stm32cube.ide.mcu.externaltools.cubeprogrammer.linux64_1.0.0.201904021149/tools/bin/STM32_Programmer_CLI
Error in STM32CubeProgrammer

Projet de test

importer le projet depuis le zip: http://homepages.laas.fr/bvandepo/files/iut/nucleo_stm32_2020/Proj_filtrage_i2c.zip

File->Import->General->Project from Folder or Archive
Archive
choisir le fichier .zip
Finish
Modifier dans les propriétés du projet les 4 dossiers comme indiqué:

Compiler, icone debug puis icone play

Le port Serial est accessible via:

miniterm.py /dev/ttyACM0 

Sous windows à l'IUT, utiliser

S:\commun\2EN\Telecom_Num_S3\PuTTYPortable\PuTTYPortable.exe

Serial line: COM20

Speed: 9600

Connnection type: Serial

choisir workspace dans:

H:\STM32CubeIDE\workspace_1.0.2

Projet Hugues avec sigfox: http://homepages.laas.fr/bvandepo/files/iut/nucleo_stm32_2020/Proj_objcon_l152.zip

Importer le projet sous forme d'archive (cela rajoute un niveau de sous dossiers: Proj_objcon_l152.zip_expanded\ )

Changer les PATH (Projet, clic droit, properties,C/C++ Build, Build Variables:

FIRMWARE_PATH
H:\STM32CubeIDE\workspace_1.0.2\Proj_objcon_l152.zip_expanded\Projet_ObjCon_L152\Drivers
HAL_ARDUINO_PATH
H:\STM32CubeIDE\workspace_1.0.2\Proj_objcon_l152.zip_expanded\Projet_ObjCon_L152\Drivers\HAL_Arduino
SIGFOX_LIB_PATH
H:\STM32CubeIDE\workspace_1.0.2\Proj_objcon_l152.zip_expanded\Projet_ObjCon_L152

Utilisation sous Windows IUT

File-Import→Existing Project→Archive:

S:\commun\2EN\Projet_IOT\SystEmbarq\Proj_objcon_l152_sgfx_ok_cpp_pasdelib_reorg.zip

Pour lancer Putty afin d'ouvrir la console série:

Touche Windows+r:
S:\commun\2EN\Telecom_Num_S3\PuTTYPortable\PuTTYPortable.exe

En cas de déconnexion du port série, clic droit sur la barre de fenêtre de Putty, puis “Restart Session”

en cas de transaction en lecture infructueuse (NACK)…

Project→Reset

nucleo2020.txt · Dernière modification: 2020/03/12 15:06 par bvandepo