Outils pour utilisateurs

Outils du site


ci

Eagle 6.1 sous linux 64 bits

télécharger le binaire de la librairie manquante: https://homepages.laas.fr/bvandepo/files/libpng14.so.14.12.0

régler les droits sur le fichier pour protéger la librairie

chmod 755 libpng14.so.14.12.0
sudo chown root:root libpng14.so.14.12.0

copie à la main de la librairie manquante:

sudo cp libpng14.so.14.12.0 /usr/lib/i386-linux-gnu/ 

création des liens symboliques:

sudo ln -s /usr/lib/i386-linux-gnu/libpng14.so.14.12.0 /usr/lib/i386-linux-gnu/libpng14.so
sudo ln -s /usr/lib/i386-linux-gnu/libpng14.so.14.12.0 /usr/lib/i386-linux-gnu/libpng14.so.14

Réalisation de circuits imprimés

http://www.seeedstudio.com/depot/fusion-pcb-service-p-835.html?cPath=185

http://batchpcb.com/index.php/Products

ils les fabriquent chez : http://www.goldphoenixpcb.com/

Etude et Réalisation de Circuit IMprimé 64 bis, rue de la Providence 31500 Toulouse

Téléphone : 05-61-20-69-57 Télécopie : 05-61-20-40-80 Email : ercim.ci@numericable.fr

http://perso.numericable.fr/ercim.ci/Tarifs/

boussole iut

microchip-update-2.lbr PIC16F628A boitier SOIC 18 broches

prendre PIC16F62* en package SO-18W

les composants résistances, capas etc sont dans la librairie rcl

pour les via

change drill 0.0236
change diameter 0.056
change shape square

pour les pistes

change width 0.016
  

view→grid

passer à    0.025

cocher view→grid, choisir mm

pour avoir les dimensions, cocher sous l'oeil puis sur le ci pour poser la croix. la distance en relatif s'affiche avec “R ”

CAM processor
  activer  (Top ou bottom) pad via dimension  
décocher fill pads
donner un nom au fichier .ps bottom ou top  
process job

ps2pdf ->

http://www.cadsoftusa.com/eagle-pcb-design-software/new-in-v6/?language=en

pour passer un composant sur la face bottom: utiliser l'outil Mirror ( [] )

pour changer un texte: utiliser l'outils info (I)

pour selectionner un objet parmi plusieurs au même endroit, click droit, puis gauche sur next jusqu'à ce que l'objet souhaité soit en surbrillance

Pour créer un composant rapidement

-Premièrement, VERIFIER QU'IL N'EXISTE PAS DEJA!!!

Package

-dans librairie, localiser un/des composant(s) proche(s)

-Cliquer sur package, et le selectionner

-Outils Group (rectangle pointillé), encadrer les parties à copier

-Outils Copy (2 petits hommes), CTRL +cliquer droit, puis click gauche sur copy group

-Ouvrir sa propre lib

-créer le nouveau package (bouton package puis donner un nouveau nom)

-Outils Paste (jaune), bien centrer ce qu'on colle par rapport à la croix blanche qui définit le centre du composant

-Sauver

-Pour changer diamètres trous etc…, cliquer sur l'outils I, on peut saisir les unités par exemple 5mm, 5mil, 5 rien (inch par defaut). On peut aussi changer le placement précis, en rentrant les positions, faire apply pour voir l'effet du changement sur le package.

Symbol

-Procéder de la même façon pour le symbole

Device

Il faut associer un package et un symbole et définir les broches pour créer le composant

-Créer le nouveau device et lui donner un nom

-Cliquer sur l'outils Add puis selectionner le symbole et le positionner sur la vue. Eventuellement, il peut y avoir plusieurs symboles (par exemple un pour l'alim…)

-A droite, cliquer sur new pour choisir un nouveau package

-A droite, cliquer sur connect et faire les associations

Utilisation du nouveau composant

Dans l'outils de saisie de schéma, faire library→Use et aller chercher le fichier .lbr qui contient le nouveau composant

EAGLE UP POUR VOIR MODELE 3D

http://eagleup.wordpress.com/installation-and-setup/

http://sketchup.google.com/intl/fr/download/gsu.html

sudo port install imagemagick sudo cp “/Users/bvandepo/Downloads/eagleUp4.3/Sketchup Plugin/eagleUp_import.rb” “/Library/Application Support/Google SketchUp 8/SketchUp/plugins” sudo cp “/Users/bvandepo/Downloads/eagleUp4.3/Eagle ULP/eagleUp_export.ulp” “/Applications/EAGLE/ulp” sudo cp -r “/Users/bvandepo/Downloads/eagleUp4.3/models” “/Applications/EAGLE” sudo cp -r “/Users/bvandepo/Downloads/eagleUp4.3/demo files” “/Applications/EAGLE”

dans eagle

File->Ulp run -> eagleUp_export.ulp

pour models saisir: /Applications/EAGLE/models/

DANS SKETCHUP:

Plugins->model import
  eagleUp_export.ulp goes to C:\Program Files\EAGLE-5.11.0\ulp
  eagleUp_import.rb goes to C:\Program Files\Google\Google SketchUp 8\Plugins
  the content of /models can be placed anywhere. I recommend to copy it near your libraries, for example in C:\Program Files\EAGLE-5.11.0\models
  the Eagle demo files can be placed anywhere.

max3280E

boitier: TSSOP 4.40mm 20 broches

Device = mise en relation entre un Symbol et un Package ( éventuellement, il peut y avoir plusieurs symboles, 1 pour l'alim par exemple)

pour trouver le composant le plus proche, faire add dans une schématique et se balader avec les fleches pour balayer…

ouvrir librairie maxim.lbr sauver lib sur le bureau: maximavec3280.lbr

cliquer sur bouton edit symbol, puis dans le champ new, rentrer le nom MAX3280E

sauver puis ouvrir le symbol MAX3222 pour copier coller

define a group, encadrer tout

click droit, copy group

cliquer sur bouton edit symbol, puis MAX3280E

Edit→Paste et cliquer pour positionner le symbole, centré sur la croix

renommer les broches: icone R2/10k; cliquer sur la broche à renomer puis saisir le nouveau nom

pour créer des nouvelles broches, icone copy, puis cliquer sur l'original et placer ailleurs

(ou alors icone “draw a pin”) (click droit pour rotation)

icone “i”, cliquer sur les pin et régler les directions (in/out/power etc…)

cliquer sur bouton edit device, puis dans le champ new, rentrer le nom max3280E

dans la fenêtre package; cliquer new et choisir TSSOP 20

copier la description depuis la datasheet

Edit→Add, choisir le max3280E et le déposer sur la page, centré sur la croix

mettre en relation les broches du boitier avec les pin du symbole

bouton connect, en bas à droite: cliquer sur les 2 puis connect, faire cela pour chaque broche

ensuite pour pouvoir utiliser la nouvelle librairie, dans la schématique, Library→Use et selectionner le lbr créé

doc eagle

scripts pour impression

http://www.instructables.com/id/Automating-Eagle-export-and-preparing-for-printing/

scripts dans /home/bvandepo/eagle-6.1.0/scr/prsch.scr

DISPLAY None
DISPLAY Nets Busses Symbol Names Values Info Guide
EXPORT IMAGE /home/bvandepo/eagle/pr/eagle_export_sch.png  600;

invoquer le script dans eagle en tapant dans l'invite (pavé blanc)

 script prsch

scripts dans /home/bvandepo/eagle-6.1.0/scr/pr.scr

DISPLAY None
DISPLAY Bottom Pads Vias
EXPORT IMAGE /home/bvandepo/eagle/pr/eagle_export_bottom.png MONOCHROME 600;
DISPLAY None
DISPLAY Top Pads Vias
EXPORT IMAGE /home/bvandepo/eagle/pr/eagle_export_top.png MONOCHROME 600;
DISPLAY Bottom Top Pads Vias  Unrouted Dimension tPlace bPlace
EXPORT IMAGE /home/bvandepo/eagle/pr/eagle_export_all.png MONOCHROME 600;
DISPLAY ALL
RATSNEST

invoquer le script dans eagle en tapant dans l'invite (pavé blanc)

 script pr

voir d'autres commandes telles que print: http://web.mit.edu/~xavid/arch/i386_rhel4/help/104.htm

Export eagle vers Kicad

soudure cms

vidéos soudure au four qui repositionne les composants par capillarité

soudure qfn

cem

Réalisation circuit imprimé

thermo transfert depuis imprimante laser: http://www.youtube.com/watch?v=L0QB8_mGUoE

Site de Pooling

9.9$ les 10 circuits en 100*100mm: https://www.seeedstudio.com/fusion_pcb.html

ci.txt · Dernière modification: 2017/01/20 22:43 par bvandepo